m

ciscossl_failed

I currently use the Cisco AnyConnect Secure Mobility Client (4.0.00048) with Windows 8.1 and as of this morning receive the above error – Failed to initialize connection subsystem. After a quick Google, I don’t appear to be alone. It turns out the recent string of updates released by Microsoft looks to be the cause.

So how to fix? The below looked to have worked for me –

  1. Close the Cisco Anyconnect client (and make sure to right click and quit the system tray icon as well)
  2. Open up My Computer and browser to “C:\Program Files (x86)\Cisco\Cisco AnyConnect Secure Mobility Client\”
  3. Right click on ‘vpnui.exe’
  4. Click the Compatibility tab and set it for Windows 8 as below
    ciscossl_compat
  5. Click Apply, then Ok.
  6. You’re now good to go!

It looks like the issue is due to one of the Security Updates for Internet Explorer with some further information via KB 3023607

Thanks to some info on Nick Litten’s Blog post which pointed me in the right direction. Check out his article here. From user comments it looks like it’s impacted a few different OS/IE and Client versions.

 

1 comment

  1. 04/03/2015 at 8:32 PM anton

    thanks for real help. it’s work!